• 検索結果がありません。

SIP SDP(Session Description Protocol) RTSP(Real-time Streaming Protocol) RTP(Real-time Transport Protocol) IP 1 [1] 1: IP RTP(Real-Time RFC1889 Transf

N/A
N/A
Protected

Academic year: 2021

シェア "SIP SDP(Session Description Protocol) RTSP(Real-time Streaming Protocol) RTP(Real-time Transport Protocol) IP 1 [1] 1: IP RTP(Real-Time RFC1889 Transf"

Copied!
11
0
0

読み込み中.... (全文を見る)

全文

(1)

C4

無線ネットワークの通信品質特性

担当 電気電子情報工学専攻 東野 武史 [email protected]

1

ワイヤレス

IP

電話の相互接続とその通話品質

1.1

実験目的

1. 異種ワイヤレスIP電話の相互接続のしくみを理解する.受信電力と伝送速度の違 いについて理解する.ワイヤレスIP電話システムの音声品質評価手法について理 解する. 2. 電波を使った位置検出方式を設計し,その仕組みを理解する.

1.2

実験原理

1.2.1 IP電話

IP電話(Internet Protocol telephone)は,IPネットワークを介することで音声のやり 取りを実現する電話サービスである.VoIP(Voice over Internet Protocol)は,IPネット ワークにおいて音声情報やシグナリングのやりとりを行う為の技術やプロトコル群の総 称である.プロトコルとは,通信分野における通信規約を示し,電話機や交換機間にお いては信号方式のことを意味する.IP電話に必要な制御には,網アクセス制御,呼制御, 端末間制御がある.網アクセス制御(Network Access Control)は,IPネットワークに対 する接続や,IPアドレスの決定,帯域状態の決定,接続端末の状態管理などの制御を示 す.呼制御(Call Control)とは,電話における回線接続や切断,発呼や着呼,かけた相手 を呼び出すシグナリングなどを意味する.端末制御(Terminal Control)とは,互いの論 理的な接続が完了した端末同士が用いるプロトコル,やり取りを行うメディアの種類,音 声のデジタル変換の圧縮形式といったストリーミング(streaming)に関する制御である. IP電話のプロトコルは,上記の制御の組合せからなり,H.323やSIP(Session Initiation Protocol: セッション開始プロトコル)が代表的である. H.323は,もともと公衆電話網で用いられた技術がベースとなっており,IPネットワー クにおける技術的な拡張が難しいとされている.これに対しSIPは,IPネットワーク上 での音声,画像のやりとりの実現が基準となっており,プロトコル構造がシンプルであ り,拡張しやすいといった特徴をもつ.H.323と大きく異なる点は,H.323のようなプ ロトコル群ではなく, インターネットで用いるHTTPやFTPなどと同様,アプリケー ション層の一部としてセッション機能をもつプロトコルにすぎなという点である.ここ で,セッションとは2点間の通信において情報をやり取りをするために設定する論理的 な接続関係である.IPネットワークの場合はパケットの転送経路と双方の認識によって セッションが確立する.通話やデータ転送が終了した段階では,セッション終了が必要 となる.

(2)

SIPでは,SDP(Session Description Protocol)という情報記述プロトコルを用いてセッ ションのための記述方法を決め,RTSP(Real-time Streaming Protocol)を用いて,スト リーミングをやり取りし,RTP(Real-time Transport Protocol)によって送信先との同期 を取り音声品質の制御を行うことでIP電話サービスを実現する.表1に各種プロトコル の概要を示す[1]. 表1: IP上でマルチメディア通信を実現するためのプロトコル プロトコル ドキュメント 内容 RTP(Real-Time RFC1889 音声,文字,映像などのメディアストリーム Transfer Protocol) のパケット化などを定めている SDP(Session RFC2327 セッションの内容に関する Description Protocol) 情報のやり取りを定めている. SIP(Session RFC3261 セッションを確立する Initiation Protocol) ためのプロトコル H.323 ITU-T勧告 H.323 パケットベースのマルチメディア 通信システム 1.2.2 SIPのネットワーク構成要素

SIPにおける端末に相当する部分をUA(User Agent:ユーザエージェント)と呼ぶ.電 話をかける側をUAC(User Agent Client),電話を受ける側をUAS(User Agent Server)

と呼ぶ.電話サービスを実現するには,IPネットワーク上にプロキシサーバ,リダイレ クトサーバ,登録サーバ,ロケーションサーバなどのサーバ機能を必要とする.プロキ シサーバ(Proxy server)は,電話の相手の場所を特定し,相手先を呼び出す機能を持つ. リダイレクトサーバ(Redirect server)は,相手のアドレスが変更された場合,新たなア ドレスをロケーションサーバに問合せることでUAに対して新しいアドレスを通知する. 登録サーバ(Register server)は,UAからの要求によってロケーションサーバに対して新 規登録処理,更新処理などを行う.ロケーションサーバ(Location server)は,UAの情 報を保持しUAの位置情報を提供する. 1.2.3 SIPメッセージ

SIPのシグナリング制御が行われるテキストによる情報をSIPメッセージ(SIP message)

と呼ぶ.SIPメッセージは,複数行のテキストで構成され,スタートライン,ヘッダ,ボ ディから成る. UACからUASへのメッセージをリクエストメッセージと呼び,メソッドと呼ばれる 目的別の6種類のフィールドを持つ.スタートラインにセットされる.表2に代表的な SIPメソッドを示す[2]. INVITEは,呼の設定,つまり電話をかける動作である.IPアドレスやポート番号, 符号化方式の要求項目が含まれる.呼の開放にはBYEが用いられる. ACKは,INVITEに対するサーバからの応答を受信したという確認メッセージである. サーバ機能を問合せるには,OPTIONSが用いられる.CANCELは,リクエストメッセー

(3)

表 2: SIPメソッドと機能

メソッド 機能

INVITE UACとUAS間でセッションを確立

ACK INVITEに対する最終応答 CANCEL セッション確立のキャンセル BYE セッション終了 OPTIONS 相手の機能能力の問合せ REGISTER 位置情報をロケーションサーバへ登録 INFO セッション状態の通知 ジに対する応答を受信する以前における,リクエストの取り消しに用いる.REGISTER は,クライアントがサーバに対してロケーション情報を登録する際に用いられる. 応答メッセージのことを,レスポンスメッセージという.表3に代表的なレスポンス メッセージを示す[2]. 表 3: SIPのレスポンス タイプ 意味 コード 詳細 仮応答 リクエスト受信 100 Trying (Provisional)  処理中 180 Ringing 最終応答 リクエスト成功 200 OK

(Final) リダイレクションフォワーディング 301 Moved permanently

リクエストミス 400 Bad Request 401 Unauthorized

リクエスト失敗 5** Server Failer

グローバルエラー応答 600 Busy Everywhere 604 Does Not Exist Anywhere 606 Not Acceptable

1.2.4 端末間のSIP接続シーケンス

図1に端末間のSIP接続シーケンスを示す.UACが電話をする場合,まず,INVITE

メソッドをリクエストメッセージとしてSIPサーバへ要求をかける.SIPサーバではロ ケーションに応じて場所を問合せ,相手先UASに対してINVITEメッセージを送信する.

これを受けたUASはベルを鳴らし,SIPサーバに対して,ステータスコード180の

Ringingのレスポンスメッセージを応答する.SIPサーバはこれを中継しUACに応答 する.

UASが受話器をとるとステータスコード200のOKレスポンスメッセージをSIPサー バ経由でUACに応答する.その後,UACがSIPサーバ経由でACKメソッドをUASに 送信し,これをUASが受け取った段階で会話が始まる.

(4)

切断する場合は,BYEメソッドをリクエストメッセージとしてSIPサーバ経由で相手 に送信し,ステータスコード200OKのレスポンスメッセージを受信した段階でセッショ ンが終了する. 図1: 端末間SIPのシーケンス 1.2.5 音声のMOS評価 音声をたくさんの人に聞かせて,音声尺度に主観的な評点をつけさせ,これを統計的 に処理し平均(最低でも10サンプル以上必要)の評点を得るのがオピニオン評価法で ある.評点をMOS(Mean Opinion Score:平均オピニオンスコア)値と呼ぶ.いくつかの

MOS試験のうち,絶対品質尺度(Absolute Category Rating : ACR )について説明す る.ACRでは,被測定系の品質を絶対品質で評価する(表4).その他のACRの例として, 表4: MOS Score 品質 5 非常に良い(Exellent) 4 良い(Good) 3 まあ良い(Fair) 2 悪い(Poor) 1 非常に悪い(Bad)

(5)

文章の意味を理解する為に必要とされる努力を尺度とする聞き取り努力尺度( Listening Effort Score )もある.聞き取り努力尺度のスコアを示す(表5).

表 5: 聞き取り努力尺度

Score 文章を理解するために必要される努力

5 完全にリラックスできる

(Complete relaxation possible; no effort required) 4 注意が必要だが,特別な努力は必要ない

(Attention necessary; no appreciable effort required) 3 少しの努力が必要

(Moderate effort required) 2 かなりの努力が必要

(Considerable effort required) 1 どんなに努力しても意味が理解できない

(No meaning understood with any feasible effort)

1.2.6 PSQM ,PESQとR値

通話品質をソフトウェアを用いて客観的に評価するためのベンチマークとしてPQSM ( Perceptual Speech Quality Measurement : 知覚的音声会話品質計測) がある.ITU-T

がP.861として韓国したものであり音声コーデックの評価に用いる.コーデックをとお

した被試験信号と,コーデックを通さない参照信号とを,それぞれPSQMシステムへ入 力することで差異を判定し、音声品質テスターやプログラムによる客観的な評価を行う.

2001年新たな客観評価方法としてP.862のPESQ ( Perceptual Evaluation of Speech Quality ) が勧告された.IPネットワーク内を音声情報が通過する際のパケット損失に よる音声劣化を考慮する方式である. 図2: PSMQ値

1.3

実験の使用機器とネットワーク環境

1.3.1 構成 携帯電話端末(4台),無線LANアクセスポイント(1台),PHS CS(1台),有線ハブ(1 台),ノートPC(2台),固定電話(1台)

(6)

図3にネットワーク図を示す.ネットワークアドレスの異なる二つのネットワークが 接続している.()内はホストアドレスを示す. 図3: 実験ネットワーク図

1.4

実験方法

1.4.1 受信電力とスループットの測定 1. 図3のノートPCのスループット解析ソフトを起動する. 2. APの設定を変更しを伝送モードを固定する。 3. 無線LAN物理レイヤのデータレートに対するTCPスループットを計測する。 4. 横軸に無線LANの伝送レート、縦軸にTCPスループット[bps]をとって図示する (表6)。 1.4.2 実験結果と考察のポイント 無線LANの物理レイヤ伝送レートとTCPスループットの違いについて考察せよ。 表6: 無線LANの物理レイヤ伝送レートと主な変調方式 伝送レート 6 9 12 18 24 36 48 54 Mbps サブキャリア  BPSK BPSK QPSK QPSK 16- 16- 64-

64-変調方式 QAM QAM QAM QAM

(7)

1.4.3 背景トラヒック量と音声、映像品質評価 1. N900iL,N902iL音声端末間で音声セッションを開始する 2. PCを使って背景UDPトラヒックを発生させる 3. 各トラヒック毎にMOS評価を行う(10回). 4. 音声セッションを動画セッションにかえて同様のMOS評価を行う。 1.4.4 実験結果と考察のポイント 背景トラック量と音声·動画像の品質評価を図示し、相関関係を考察せよ.

1.5

検討課題

• 音声符号化方式(G.711,G722,G.723.1,G.728,G.729)についてまとめよ. • 無線伝搬における自由空間伝搬損失について調べ,周波数の違いと伝搬距離,伝搬 特性について考察せよ.

2

電波を使った測距

無線を用いた位置検出方式には,GPS(Global positioning System)や携帯電話の基地 局の電波を用いるシステムやRFID(Radio Frequency Identification)などがあり,電波 の到達距離や目的とする目的の測距精度に応じて使い分けられている. 本実験は,無指向アンテナを用いて無線機器間の距離を推定する.これは、電波の伝 搬損失ならびに遅延時間から無線機器間の距離推定を行うため,伝搬路のインパルス応 答をネットワークアナライザにより観測する実験である.

2.1

実験原理

2.1.1 インパルス応答と周波数応答 フーリエ級数展開によって周波数の異なった正弦波を数多く加え合わせると全体の和 としてどんな種類の一般的な時間関数でも近似することができる.これらの正弦波の和 を、成分のすべての組にわたって積分したものに置き換えた信号表示ができることにな る.一般的な条件のもとで、波形a(t)は,次のフーリエ積分の形で表す. a(t) = ∫ ∞ −∞A(f )e j2πf tdf (1) A(f )をa(t)の周波数スペクトルという. 線形系に信号を通すとその出力は,時間領域では畳み込みにより,周波数領域ではス ペクトルの積でそれぞれ表される.系のインパルス応答をh(t),入力をvi(t)とすると, その出力時間応答vo(t)は, vo(t) = vi(t)⊗ h(t) = ∫ ∞ −∞vi(τ )h(t− τ)dτ (2)

(8)

によって与えられる.上式はたたみこみ積分を表す.各時間関数vi(t),vo(t),h(t)の周 波数スペクトルをVi(f),Vo(f ),H(f )とすると, Vo(f ) = H(f )Vi(f ) (3) で与えられる.本実験で用いるネットワークアナライザは,簡単に言うとH(f ),h(t) を 観測する測定器である. ネットワークアナライザ(以下,NA)が測定する帯域幅と到着時間観測の時間分解能 について述べる.NAは,その入出力間において単一正弦波を掃引(スイープ)すること で周波数応答を得て,これをフーリエ変換することで時間応答を得ている.つまり,NA からは帯域幅Bw,矩形状のスペクトルをもつ時間信号を送信しており,これは高さBw, 幅1/Bwの矩形パルスと等価である.よって観測したh(t)上で1/Bw秒以上はなれた点 だけを分解できる.別の言い方をすると,信号波形が1/Bw秒以上離れて変化するなら ば,NAはその変化を観測することができる[3]. 2.1.2 アンテナの指向性[4] 微小ダイポールアンテナおよび半波長ダイポールアンテナの指向性関数をそれぞれDH, DDとすると次式で表される. DH = sin θ, (4) DD = cos(π2cos θ) sin θ (5) ただし,θはアンテナ軸からの角度である. 二つのアンテナから最大放射方向で,同じ距離の点において基準アンテナの放射電力 P0,試験アンテナの放射電力がPの時,それらのアンテナからの電界強度が等しくなっ たとすると,試験アンテナの利得Gは次式で表される. G = P0 P (6) 基準アンテナとして半波長ダイポールアンテナを用いたときは相対利得と呼び,等方性ア ンテナを用いたときは絶対利得という.半波長ダイポールアンテナの絶対利得は,2.14dB である. 2.1.3 空間伝搬損失の計算[4] 宇宙空間や短距離見通し通信の場合の伝搬損失Γは,以下に示すフリスの伝達公式(自 由空間伝搬損失)で計算できる. Γ = 10 log ( 4πD λ )2 (7) =20 log4πDλ (8) ここで,Γ,λ,Dは,それぞれ自由空間伝搬損失[dB],電波の波長,送受信アンテナ間 距離[m]である.2.4GHz帯の場合,距離1mのときの自由空間伝搬損失はほぼ40dBと なる.以下のように変換すると計算が簡単になる. Γ = 40 + 20 log D (9)

(9)

フリスの伝達公式では距離の2乗に比例して損失が増加するが,見通しが悪い場所や 反射の多い場所では3.5乗に比例するとして計算する. Γ[dB] = 10 log ( 4πD λ )3.5 (10) = 35 log(4πD/λ) (11) なお、周辺状況によっては,3乗則や4乗則で計算した方が実測と合う場合がある. 2.1.4 受信電力の計算[4] 受信電力Prは,次式で計算できる.ただしマージンを含んでいない. Pr= Pt− Lf t+ Gat− Γ + Gar− Lf r (12) ここで,Pt, Lf t, Gat, Gar, Lf rはそれぞれ,送信電力,送信機給電線損失,送信アンテ ナ利得,受信アンテナ利得,受信機給電線利得である.

2.2

実験方法

実験の手順を以下のように行う. 1. ネットワークアナライザのキャリブレーションを行う.中心周波数を1.9GHzとし, 帯域幅(SPAN)をBw=1GHzとする. 2. 3脚に乗せた無指向性アンテナ(オムニアンテナ)を任意の位置に配置する. 3. 送信点から距離に対する、電力損失および遅延時間を測定する。 4. 測定点をかえて、上記を繰り返す。測定点の数は10とする。 図4はインパルス応答の測定例である.横軸は遅延時間、縦軸は振幅応答値を表す.最 も小さい遅延時間をもつ成分が直接波であり、これに床面反射波などが続く.直接波の 応答から伝搬損失と伝搬にかかった遅延時間を測定する.ネットワークアナライザ上で マーカを測定したい点に合わせて、読み取る.

2.3

遅延時間を使った距離測定

1. 横軸に距離,縦軸に遅延時間の測定値をプロットする. 2. 上図に,光速と距離から算出した遅延時間の線を加える. 3. 測定地点毎に距離推定誤差を算出する.

(10)

図4: インパルス応答から伝搬損失と遅延時間を測定する方法

2.4

伝搬損失を使った距離測定

1. 横軸に距離,縦軸に伝搬損失の測定値をプロットする. 2. 上図に,2乗則ならびに3乗則の理論線を加える. 3. 測定値に対して最小二乗近似を用いて伝搬損失を近似し、カーブフィッティングを 行う. 4. 測定地点毎に距離推定誤差を算出する.

2.5

調査課題

1. 位置検出誤差の原因について考察せよ.また,この誤差要因を克服し,特性改善の ための対策を述べよ. 2. 世の中に存在する位置検出方式を1つ挙げ,その仕組みをまとめよ。

2.6

レポート提出先

吹田キャンパス工学部電気系E2–222の部屋の前の封筒にいれる。締め切り日は実験終 了日から2週間後のお昼12時半。

(11)

参考文献

[1] Henry Sinnreich, Alan B.Johonsoton共著,阪口克彦 監訳“マスタリングTCP/IP SIP編,” オーム社, 2003年, pp. 13-14.

[2] 小泉修 著“図解でわかるVoIPのすべて,” 日本実業出版社, 2003年, pp. 210-215. [3] S. スタイン 他, 現代の通信回線理論,森北出版

図

図 1 に端末間の SIP 接続シーケンスを示す. UAC が電話をする場合,まず, INVITE メソッドをリクエストメッセージとして SIP サーバへ要求をかける. SIP サーバではロ ケーションに応じて場所を問合せ,相手先 UAS に対して INVITE メッセージを送信する.
表 5: 聞き取り努力尺度
図 3 にネットワーク図を示す.ネットワークアドレスの異なる二つのネットワークが 接続している. () 内はホストアドレスを示す. 図 3: 実験ネットワーク図 1.4 実験方法 1.4.1 受信電力とスループットの測定 1
図 4: インパルス応答から伝搬損失と遅延時間を測定する方法 2.4 伝搬損失を使った距離測定 1. 横軸に距離,縦軸に伝搬損失の測定値をプロットする. 2. 上図に,2乗則ならびに3乗則の理論線を加える. 3

参照

関連したドキュメント

自然電位測定結果は図-1 に示すとおりである。目視 点検においても全面的に漏水の影響を受けており、打音 異常やコンクリートのはく離が生じている。1-1

As a member of CBD and the Nagoya Protocol, Indonesia has the consequences to immediately implementing the provisions of CBD and Nagoya Protocol, including the obligation

・SMTP :Simple Mail Transfer Protocol (電子メール). ・LDAP :Lightweight Directory

本製品のIPアドレスが不明な場合は、AXIS IP UtilityまたはAXIS Device Managerを使⽤して、ネットワー

チツヂヅに共通する音声条件は,いずれも狭母音の前であることである。だからと

CN 割り込みが発生した場合、ユーザーは CN ピンに対応する PORT レジスタを読み出す

戦略的パートナーシップは、 Cardano のブロックチェーンテクノロジーを DISH のテレコムサービスに 導入することを目的としています。これにより、

筋障害が問題となる.常温下での冠状動脈遮断に