• 検索結果がありません。

Although we proposed the ECN-based methods to mitigate congestion in adaptive video streaming over ICN, the following point is not well investi-gated in each method.

• CAAS with ECN: In adaptive video streaming, the state-of-the-art ABR algorithm based on deep reinforcement learning has been emerged in the IP network [65]. In this approach, end-to-end throughput is mainly considered as an input to the learning model for the bitrate output.

Therefore, to apply the learning-based ABR algorithm to adaptive video

streaming over ICN, we are planning to investigate the behavior when the explicit congestion feedback from routers is input to the learning model by CAAS with ECN.

• CAAS with ECN: ICN natively supports multipath name-based for-warding of Interest / Data packet [4] and enables the router to adaptively route the Interest / Data packet according to congestion [67]. CAAS with ECN does not work when the Interest packet for the uninitialized video content arrives due to adaptive name-based routing. Therefore, we are planning to introduce a method of the initialization for the newly requested video content at the router.

• CAAS with ECN: The cache hit on the router makes the effect of the ECN control incorrect because the ECN control is unable to always feedback the end-to-end bottleneck information. Therefore, we need to design the ECN control when the router receives the Interest packet of the excessive high bitrate for end-to-end bottleneck due to cache miss in downstream.

• CASwECPN: CASwECPN is unable to use cache storage effectively during non-congestion because it prevents the router from making the new content cache to downstream routers for congestion avoidance.

Therefore, to improve cache efficiency, we need to design the coop-erative system in which routers offload the explicitly cached contents to cache storage closer to the client.

• CASwECPN: Although CASwECPN improves cache efficiency, it be-comes ineffective when the explicitly cached content is purged due to cache eviction. Therefore, we need to optimize CASwECPN for the size of router’s cache storage.

• CASwECPN: In CASwECPN, the router has not been able to avoid congestion by the time the router receives the first content request from the client by ECPN. To mitigate congestion more quickly, we’re plan-ning to introduce the explicit bitrate reduction in CAAS with ECN to CASwECPN.

Bibliography

[1] Cisco, “Cisco Visual Networking Index: Forecast and Trends, 2017–2022,” 2017.

[2] G. Peng, CDN: Content distribution network, 2004, [online] Avail-able: https://arxiv.org/abs/cs/0411069.

[3] K. Pentikousis, Ed. et al.”Information-Centric Networking: Baseline Scenarios,” RFC 7476, 2015.

[4] D. Kutscher et al., ”Information-Centric Networking (ICN) Research Challenges,” RFC 7927, 2016.

[5] B. Wissingh et al., ”Information-Centric Networking (ICN): Content-Centric Networking (CCNx) and Named Data Networking (NDN) Ter-minology,” RFC 8793, 2020.

[6] C. Dannewitz, ”NetInf: An Information-Centric Design for the Future Internet, ” in Proceedings of 3rd GI/ITG KuVS Workshop on The Future Internet, 2009.

[7] C. Westphal et al., “Adaptive Video Streaming over Information-Centric Networking (ICN),” RFC 7933, 2016.

[8] Samain et al., ”Dynamic Adaptive Video Streaming: Towards a System-atic Comparison of ICN and TCP/IP,” in IEEE Transactions on Multi-media, vol. 19, no. 10, pp. 2166-2181, 2017.

[9] P. Juluri, V. Tamarapalli, and D. Medhi, “Measurement of Quality of Experience of Video-on-Demand Services: A Survey,” in IEEE Com-mun. Surveys Tuts., vol. 18, no. 1, pp. 401–418, 2016.

[10] ISO-IEC 23009-1:2012 Information Technology. Dynamic Adaptive Streaming over HTTP (DASH).

[11] J. Jiang, V. Sekar, and H. Zhang, ”Improving Fairness, Efficiency, and Stability in HTTP-based Adaptive Video Streaming with FESTIVE,” in Proc. of ACM International Conference on Emerging Networking Ex-periments and Technologies, 2012.

[12] G. Tian and Y. Liu, ”Towards Agile and Smooth Video Adaptation in Dynamic HTTP Streaming,” in Proc. of ACM International Conference on Emerging Networking Experiments and Technologies, CoNEXT, 2012.

[13] Z. Li et al., “Probe and adapt: Rate adaptation for http video streaming at scale,” in IEEE JSAC., vol. 4, no. 32, pp. 719-733, 2014.

[14] X. Yin, A. Jindal, V. Sekar, and B. Sinopoli, “A Control-Theoretic Ap-proach for Dynamic Adaptive Video Streaming over HTTP,” in Proceed-ings of ACM SIGCOMM, pp. 325-338, 2015.

[15] J. Kua, G. Armitage, and P. Branch, ”A survey of rate adaptation techniques for dynamic adaptive streaming over HTTP,” IEEE Com-mun. Surveys Tuts., vol. 19, no. 3, pp. 1842-1866, 2017.

[16] D. H. Lee, C. Dovrolis, and A. C. Begen, “Caching in http adaptive streaming: Friend or foe?,” in Proceedings of NOSSDAV., p. 31, 2014.

[17] C. Mueller, S. Lederer and C. Timmerer, “A proxy effect analyis and fair adatpation algorithm for multiple competing Dynamic Adaptive

Stream-ing over HTTP clients,” in Proc. of the Visual Communications and Im-age Processing, pp. 1-6, 2012.

[18] N. Barman and M. G. Martini, “QoE Modeling for HTTP Adaptive Video Streaming–A Survey and Open Challenges,” in IEEE Access, vol. 7, pp. 30831-30859, 2019.

[19] R. K. P. Mok, E.W.W. Chan, X. Luo, and R. K. C, Chang, “Inferring the QoE of HTTP video streaming from user-viewing activities,” in Pro-ceedings of SIGCOMM W-MUST, pp. 31-36, 2011.

[20] S. Akhshabi, L. Anantakrishnan, C. Dovrolis, and A. C. Begen, “What happens when HTTP adaptive streaming players compete for bandwidth

?,” in Proceedings of International Workshop on Network and Operating System Support for Digital Audio and Video, pp. 9-14, 2012.

[21] S. K. Fayazbakhsh et al., ”Less pain, most of the gain: incrementally deployable ICN,” in Proc. of ACM SIGCOMM, pp. 147-158, 2013.

[22] L. Psaras, W. K. Chai, and G. Pavlou, “Probabilistic in-network caching for information-centric networks,” in Proc. of ACM SIGCOMM, pp. 55-60, 2012.

[23] D. Nguyen, K. Sugiyama and A. Tagami, ”Congestion price for cache management in information-centric networking”, in Proc. of INFOCOM WRKSHP, pp. 1-6, 2015.

[24] W. Li, S. M. A. Oteafy and H. S. Hassanein, ”StreamCache: Popularity-based caching for adaptive streaming over information-centric net-works,” in Proc. of IEEE ICC, pp. 1-6, 2016.

[25] M. A. Naeem, M. A. U. Rehman, R. Ullah and B. Kim, “A Comparative Performance Analysis of Popularity-Based Caching Strategies in Named Data Networking,” IEEE Access, vol. 8, pp. 50057-50077, 2020.

[26] Yu-Ting Yu, F. Bronzino, R. Fan, C. Westphal and M. Gerla,

”Congestion-aware edge caching for adaptive video streaming in Information-Centric Networks,” in Proc. of 12th Annual IEEE Con-sumer Communications and Networking Conference (CCNC), pp. 588-596, 2015.

[27] J. Zhou, Q. Wu, Z. Li, M. A. Kaafar, and G. Xie, “A proactive transport mechanism with explicit congestion notification for ndn,” in Proceed-ings of IEEE ICC, pp. 5242-5247, 2015.

[28] K. Schneider, C. Yi, B. Zhang and L. Zhang, “A Practical Congestion Control Scheme for Named Data Networking,” in Proceedings of ACM ICN, pp. 21-30, 2016.

[29] J. Miyoshi, S. Kawauchi, M. Bandai and M. Yamamoto, “Congestion Control for Multi-Source Content Retrieval in Content Centric Net-works,” IEICE Transactions on Communications, vol. E102.B, no. 9, pp. 1832-1841, 2019.

[30] DARPA, “INTERNET PROTOCOL,” RFC 791, 1981.

[31] M. Zhang, H. Luo and H. Zhang, ”A Survey of Caching Mechanisms in Information-Centric Networking,” in IEEE Communications Surveys and Tutorials, vol. 17, no. 3, pp. 1473-1499, 2015.

[32] M. Yamamoto, ”A Survey of Caching Networks in Content Oriented Networks,” IEICE TRANSACTIONS on Communications, vol. E99-B, no. 5, pp. 961-973, 2016.

[33] S. Podlipnig and L. B¨osz¨ormenyi, “A survey of Web cache replacement strategies,” ACM Comput. Surv., vol. 35, no. 4, pp. 374–398, 2003.

[34] M. Badov, A. Seetharam, J. Kurose, V. Firoiu, and S. Nanda,

“Congestion-aware caching and search in information-centric

net-works,” in Proc. of ACM 1st International Conference on Information-Centric Networking, ICN’14, pp.37–46, 2014.

[35] Q. Chen et al., ”Transport Control Strategies in Named Data Network-ing: A Survey,” IEEE Communications Surveys and Tutorials, vol. 18, no. 3, pp. 2052-2083, 2016.

[36] G. Carofiglio, M. Gallo, and L. Muscariello, “ICP: Design and evalu-ation of an interest control protocol for content-centric networking,” in Proceedings of IEEE INFOCOM Workshop, pp. 304-309, 2012.

[37] L. Saino, C. Cocora and G. Pavlou, ”CCTCP: A scalable receiver-driven congestion control protocol for content centric networking,” in Proceed-ings of IEEE ICC, pp. 3775-3780, 2013.

[38] C. Xia, M. Xu and Y. Wang, ”A loss-based TCP design in ICN,” in Proceedings of 22nd Wireless and Optical Communication Conference, pp. 449-454, 2013.

[39] K. Ramakrishnan et. al., “A Proposal to add Explicit Congestion Notifi-cation (ECN) to IP,” RFC 2481, 1999.

[40] B. Braden et. al., “Recommendations on Queue Management and Con-gestion Avoidance in the Internet,” RFC 2309, 1998.

[41] M. Conti, R. Droms, M. Hassan, and C. Lal “Fair-RTT-DAS: A robust and efficient dynamic adaptive streaming over ICN,” in Computer Com-munications, vol. 129, no.1, pp. 209-225, 2018.

[42] B. Ahlgren, et al., ”Design considerations for a network of information,”

in Proc. of CoNEXT Re-Arch Workshop, 2008.

[43] V. Jacobson, et al., ”Networking Named Content,” in Proc. of CoNEXT, 2009.

[44] M. Mosko, I. Solis, and E. Uzun, ”CCN 1.0 Protocol Architecture,”

Project CCNx documentation, 2013.

[45] L. Zhang, et al., ”Named Data Networking (NDN) Project,” NDN Tech-nical Report NDN-0001, 2010,

[46] D. Trossen, and G. Parisis, ”Designing and realizing an information-centric internet,” IEEE Commun. Mag., vol. 50, no. 7, 2012.

[47] T. Koponen, et al., ”A Data-Oriented (and Beyond) Network Architec-ture,” in Proc. of ACM SIGCOMM, 2007.

[48] A. Afanasyev, I. Moiseenko, and L. Zhang, “ndnSIM: NDN simulator for NS-3,” Technical Report NDN-0005, 2012.

[49] S. Mastorakis, A. Afanasyev, and L. Zhang, “On the Evolution of ndnSIM: an Open-Source Simulator for NDN Experimentation,” in Proc. of ACM SIGCOMM Computer Communication Review (CCR), 2017.

[50] K. Pentikousis et. al., “Information-Centric Networking: Evaluation and Security Considerations,” RFC 7945, 2016.

[51] S. Tokunaga, R. Nakagawa, S. Ohzahata, R. Yamamoto, and T. Kato,

“A Content Registration Method for CCN Routers with Blockchain,”

in Proc. of IEEE International Conference on Consumer Electronics – Taiwan (ICCE-TW), 2020.

[52] DASH Industry Forum. https://github.com/Dash-Industry-Forum/dash.js.

[53] N. Barman and M. G. Martini, ”QoE Modeling for HTTP Adaptive Video Streaming–A Survey and Open Challenges,” in IEEE Access, vol.

7, pp. 30831-30859, 2019.

[54] Subjective Video Quality Assessment Methods for Multimedia Applica-tions, in document ITU-T P.910 Recommendation, 2008.

[55] Methodology for the Subjective Assessment of the Quality of Television Pictures, document ITU-T BT.500 Recommendation, 2012.

[56] Reference guide to quality of experience assessment methodologies, document ITU-T G.1011 Recommendation, 2015.

[57] F. Dobrian et al., “Understanding the Impact of Video Quality on User Engagement,” in Proc. of ACM SIGCOMM, pp. 362-373, 2011.

[58] Z. Akhter et al., “Oboe: Auto-tuning Video ABR Algorithms to Con-gestion status,” in Proc. of ACM SIGGCOMM, pp. 44-58, 2018.

[59] H. Mao, R. Netravali, and M. Alizadeh, “Neural Adaptive Video Stream-ing with Pensieve,” in Proc. of ACM SIGCOMM, pp. 197-210, 2017.

[60] R. Han, et. al., ”Dynamic adaptation in an image transcoding proxy for mobile Web browsing,” in IEEE Personal Communications, vol. 5, no.

6, pp. 8-17, 1998.

[61] Q. He, C. Zhang, X. Ma and J. Liu, ”Fog-Based Transcoding for Crowd-sourced Video Livecast,” in IEEE Communications Magazine, vol. 55, no. 4, pp. 28-33, 2017.

[62] B. Rainer, C. Kreuzberger, D. Posch, and H. Hellwagner, Demo: amus-ndnSIM – adaptive multimedia streaming simulator for ndn.

[63] MPEG-DASH at ITEC/AAU, http://dash.itec.aau.at.

[64] D. M. Chiu and R. Jain, “Analysis of the increase and decrease algo-rithms for congestion avoidance in computer networks,” in Computer Networks and ISDN Systems, vol. 17, no. 1, pp. 1-14, 1989.

[65] H. Mao, R. Netravali, and M. Alizadeh, ”Neural Adaptive Video Stream-ing with Pensieve,” in Proc. of ACM SIGCOMM, pp. 197-210, 2017.

[66] W. U. Rahman, C. S. Hong and E. Huh, “Edge Computing Assisted Joint Quality Adaptation for Mobile Video Streaming,” IEEE Access. vol. 7, no. 1, pp. 129082–129094, 2019.

[67] R. Yongmao, L. Jun, S. Shanshan, L. Lingling, W. Guodong and Z. Be-ichuan, “Congestion control in named data networking- A survey,” Com-puter Communications, vol. 86, pp. 1-11, 2016.

[68] B. Rainer, D. Posch, and H. Hellwagner, “Investigating the perfor-mance of pull-based dynamic adaptive streaming in NDN,” IEEE JSAC, vol. 34, no. 8, pp. 2130–2140, 2016.

ACKNOWLEDGEMENT

I am honored to acknowledge and express my sincere thanks to all the people supporting me to accomplish this achievement.

Firstly, I wish to express my deep gratitude to Associate Professor Satoshi Ohzahata for the continuous support of my Ph.D study and related research, for his patience, motivation, and immense knowledge. So far, doing research and writing this thesis has been very challenging for me, and his precise guidance always helped me in all the level of research and writing of this thesis. I could not have imagined having a better advisor and mentor for my Ph.D study.

Secondly, I would like to acknowledge Professor Toshihiko Kato and Associate Professor Ryo Yamamoto for their valuable comments, advice and support in doing my research.

Thirdly, I would like to acknowledge Thirdly, Professor Toshihiko Kato, Professor Hiroshi Yoshiura, Professor Kazuo Sakiyama, and Associate Professor Yuuichi Sei. Their comments and suggestions for my research pre-sentations were very helpful in improving my research and completing this thesis.

Finally, I would also like to express my gratitude to my family and my friend for their moral support and warm encouragements.

関連したドキュメント